Tobias Krais
Beiträge: 478
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Autoloader macht ständig Installation kaputt

1. Jul 2017, 20:08

Hi zusammen,

auf der Domain www.promitec.de läuft ein Redaxo 5.3. Ich überwache die Seite im Moment jeden Tag, da alle paar Tage die Fehlerseite "Oops, an internal error occured" auftaucht.

Wenn das der Fall ist, lösche ich per FTP die Datei /redaxo/cache/core/autoload.cache (siehe hier: installation-r5-f46/solved-fatal-error- ... 21021.html) und lade die Seite neu und alles funktioniert wieder.

Nun habe ich gelesen, dass das ein Problem mit Redaxo 5.1 war, das aber in >=5.2 behoben sein sollte. Ich habe ein Redaxo 5.3 am Start, der Bug sollte also gelöst sein!? Ursprünglich war es ein 5.2 auf einem anderen Server. Dann habe ich es umgezogen (jetzt auf Strato) und auf 5.3 aktualisiert.

Hat jemand eine Idee, wie wir dieses nervige Autoloader Verhalten abstellen können?

Liebe Grüße,

Tobi
Zuletzt geändert von Tobias Krais am 10. Aug 2017, 22:06, insgesamt 2-mal geändert.

Tobias Krais
Beiträge: 478
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Autoloader macht ständig Installation kaputt

10. Aug 2017, 22:03

Hi zusammen,

könnte eventuell dieser Bug sein: https://github.com/redaxo/redaxo/issues/702

Liebe Grüße,

Tobi

duw
Beiträge: 1
Registriert: 11. Apr 2018, 11:55

Re: Autoloader macht ständig Installation kaputt

11. Apr 2018, 12:15

Hallo zusammen,

ich habe bei einer Website die auf Redaxo 5.3 läuft ebenfalls das gleiche Problem. In unregelmäßigen Abständen ist die Seite Offline da es Probleme mit der autoload.cache Datei gibt. Dabei wurde im Backend nichts verändert / hinzugefügt / installiert. Lösche ich diese autoload.cache Datei ist die Seite direkt wieder erreichbar. Bis sie irgendwann wieder Offline ist. Die Seite ist bei Strato gehostet. Es scheint hier einen Zusammenhang zwischen dem Problem und Strato als Hoster zu geben. Bei anderen Hostern besteht das Problem nicht.

Gibt es vielleicht einen Lösungsansatz ohne ein manuelles löschen der autoload.cache Datei?

Gruß Johannes

Tobias Krais
Beiträge: 478
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Autoloader macht ständig Installation kaputt

11. Apr 2018, 14:26

duw hat geschrieben:
11. Apr 2018, 12:15
Die Seite ist bei Strato gehostet.
Hi Johannes,

das ist ja mal spannend, dass du das Problem bei Strato auch hast. Ich habe das wie folgt gelöst: Redaxo komplett neu installiert und eingerichtet. Dann die alte Datenbank per PHPMyAdmin eingespielt. Das hat es gelöst.

Liebe Grüße,

Tobi

Zurück zu „Installation [R5]“