Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
dj-giver
Beiträge: 79
Registriert: 8. Sep 2009, 13:30

Fehler mit REX_ARTICLE[11] und REX_LINK[2]

2. Apr 2018, 00:24

Frohe Ostern an alle,

was habe ich falsch gemacht

REX_ARTICLE[11] geht wunderbar aber
REX_ARTICLE[REX_LINK[2]] wobei REX_LINK[2] die "11" hat geht nicht, es kommt aber der richtige Text raus.
Wie muß ich das ganze genau bauen.

Vielen Dank für eure Hilfe!

Benutzeravatar
runstop64
Beiträge: 353
Registriert: 23. Okt 2012, 21:34
Wohnort: Hamburg
Kontaktdaten: Website Facebook Twitter

Re: Fehler mit REX_ARTICLE[11] und REX_LINK[2]

3. Apr 2018, 00:57

Hi,

was du vor hast klappt mit den REX_VARs so nicht. Schau mal hier: https://redaxo.org/doku/master/redaxo-variablen

so könnte es gehen (ungetestet):

Code: Alles auswählen

<?php
$article = new rex_article_content(REX_LINK[2]);
echo $article->getArticle();
?>
Viele Grüße,
Daniel


studio-ahoi.de | Referenzen | Friends Of REDAXO

Zurück zu „Module/Aktionen [R5]“