Hallo,

Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen und besseren Möglichkeiten der Kommunikation haben wir uns entschlossen das Forum nur noch als Archiv zur Verfügung zu stellen. Somit bleibt es weiterhin möglich hier nach Lösungen zu suchen. Neue Beiträge können nicht mehr erstellt werden.

Wir empfehlen, für deine Fragen/Probleme Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
Konrad
Beiträge: 23
Registriert: 26. Apr 2007, 15:25

Komisches Verhalten des Medienpool

4. Apr 2012, 15:21

Guten Tag!

Wir haben auf zwei unserer Sites ein seltsames Verhalten des Medienpool, das wir nicht verstehen. Und zwar führt der Upload von Dateien, die etwas mehr als 10MB haben, dazu, dass sie nicht in den Medienpool aufgenommen werden – sondern nach dem Upload nicht mal die Seite vom Medienpool im Pop-Fenster dargestellt wird, sondern die Startseite vom Redaxo-Backend. Quasi so, als hätte man sich direkt neu angemeldet.

Im error_log von Apache gibt es keinen hilfreichen Eintrag; auch PHP schmeisst uns keinen Fehler (das loggen wir in eine getrennte Datei). Die Limits sind alle hinreichend gesetzt (max_memory 128MB, max_upload_size 60MB, TIme-Limits alle im dreistelligen Bereich). Und trotzdem, es passiert immer das gleiche.

Ich hab leider keine gute Idee, wie ich dieses Problem noch weiter eingrenzen könnte – hat jemand hier eine Idee?

Benutzeravatar
Phlogiston
Beiträge: 219
Registriert: 19. Mär 2008, 13:13
Kontaktdaten: Website

Re: Komisches Verhalten des Medienpool

4. Apr 2012, 17:00

Habe leider wahrscheinlich das gleiche Problem.
Wobei sich die Sache noch etwas kompliziert. Am Mac weigert sich der Firefox den Medienpool zu öffnen. Es öffnet sich nur die Strukturansicht. Chrome öffnet den Medienpool, allerdings als winziges Fenster, dafür kann ich in Chrome keine Templates oder Module bearbeiten. In Linux hat Chrome die gleichen Unpässlichkeiten. Am PC funktioniert alles. Auch ich habe keinen Schimmer warum das plötzlich so ist.

jimhein
Beiträge: 69
Registriert: 3. Sep 2007, 11:00
Wohnort: Berlin

Der Medienpool und Google Chrome

5. Apr 2012, 10:25

Moin Moin,

ich habe seit zwei Tagen auch ein Problem mit dem Medienpool unter Google Chrome (Windows 7).
Der Medienpool öffnet sich auf den ersten Blick nicht. Bei genauerem Hinsehen erscheint in der Taskleite eine Fensterinstanz, die sich über "rechte Maustaste + Maximieren" anzeigen lässt. Verkleinert man das Fenster so wird es wieder "unsichtbar".
Ich habe bereits alle Erweiterungen deaktiviert, PopUps in den Browsereinstellung generell erlaubt und Testweise auch das Antivirusprogramm deaktiviert. Leider ohne Erfolg...
Auf einem anderen Rechner mit Windows XP und frischem Chrome das gleiche...

Wenn ich in der redaxo/media/standard.js die auskommentierte Zeile 67 aktiviere

Code: Alles auswählen

// alert("x: "+posx+" | posy: "+posy);
öffnet sich das Fenster wie gewohnt (nachdem das Hinweisfenster geschlossen wurde).

Hmmm.... hat jemand vielleicht eine Idee, wie das eleganter gefixt werden kann?

lg
ingo

Benutzeravatar
frag-seb
Beiträge: 211
Registriert: 27. Sep 2011, 17:53
Wohnort: München
Kontaktdaten: Website

Re: Komisches Verhalten des Medienpool

5. Apr 2012, 17:06

Wenn du mit Chrome arbeiten willst musst du "moveTo" suchen und auskommentieren. Chrome hatte schon mal Probleme damit und jetzt zeit dem letzten Update wieder.

Mir ist das gestern Abend auf die Nerven gegangen und hab es so gelöst, schön ist anders aber so nervt es mich im Chrome nicht mehr.

Code: Alles auswählen


// -----------------------------------------------------------------------------
// Einfache ein Browser Typ check
function checkBrowserName(name)
{ 
	var agent = navigator.userAgent.toLowerCase(); 
	if (agent.indexOf(name.toLowerCase())>-1) 
	{ 
	return true; 
	} 
	return false; 
} 
// -----------------------------------------------------------------------------
function makeWinObj(name,url,posx,posy,width,height,extra)
{
        if (extra == 'toolbar') extra = 'scrollbars=yes,toolbar=yes';
        else if (extra == 'empty') extra = 'scrollbars=no,toolbar=no';
        else extra = 'scrollbars=yes,toolbar=no' + extra;

        this.name=name;
        this.url=url;
        this.obj=window.open(url,name,'width='+width+',height='+height+', ' + extra);

        // alert("x: "+posx+" | posy: "+posy);
	
	if(!checkBrowserName('chrome')) 
	{
        this.obj.moveTo(posx,posy);
	}
	 this.obj.focus();

        return this;
}

Hoffe das bringt dich weiter..

Gruß
Jochen

Benutzeravatar
Jan.Kristinus
Admin
Beiträge: 2166
Registriert: 24. Aug 2004, 22:11
Wohnort: Frankfurt
Kontaktdaten: ICQ Website

Re: Komisches Verhalten des Medienpool

21. Apr 2012, 18:25

Hallo,

leider hat der Chrome in der Tat ein Problem (Bug in der Laufzeit) damit, wird sicher im nächsten Update behoben sein. D.h. entweder es so machen, wie es Jochen schon beschrieben hat, oder auch einfach direkt das

// this.obj.moveTo(posx,posy);

auskommentieren. Wir werden das nicht gesondert behandeln und nicht in der nächsten 4er REDAXO Version beachten, was dann hoffentlich auch nicht mehr nötig wäre.

lg

Jan
Yakamara Media GmbH & Co. KG | Kaiserstrasse 69 | 60329 Frankfurt
Tel.: 069-900.20.60.30
http://www.yakamara.de/

Zurück zu „Allgemeines [R4]“