Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
Ben
Beiträge: 73
Registriert: 15. Aug 2006, 13:48
Wohnort: Rostock

Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 04:18

Hallo,

ich habe auf Regeneriere Artikel & Cache geklickt, das hat bisher auch immer wunderbar geklappt. Nur diesmal baut sich die Seite nicht mehr auf.

Ich bekommen folgende Fehlermeldung auf der Seite:
Fatal error: Call to a member function isOnline() on a non-object in /customers/f/d/1/domaine.de/httpd.www/redaxo/include/classes/class.article.inc.php(443) : eval()'d code on line 413

Kann mir jemand sagen was ich machen kann?

Danke. Gruß, Ben

Benutzeravatar
Xong
Beiträge: 2081
Registriert: 5. Jun 2008, 08:30
Wohnort: Halle (Saale)

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 06:57

Hi Ben,

kann es sein, dass du einen bestimmten Artikel gelöscht hast?

Schau dir mal den Modulcode aller auf der Fehlerseite eingebundenen Module an und untersuche alle Vorkommen von "isOnline".
LG,
Xong

Bild Määääääääääääääääääääääääh!

Ben
Beiträge: 73
Registriert: 15. Aug 2006, 13:48
Wohnort: Rostock

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 10:21

Hallo Xong,

ich hab keinen Artikel oder so gelöscht. Nur Regeneriere Artikel gedückt. Das muss irgendwas mit der Skriplaufzeitzu tun haben. Aber ich weiß nicht wo und wie man die ändert...

Ich hab so 800 Artikel, das scheint zu groß zu sein....

Vielleicht kennt jemand das Problem.

Gruß,
Ben

Benutzeravatar
Xong
Beiträge: 2081
Registriert: 5. Jun 2008, 08:30
Wohnort: Halle (Saale)

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 10:45

Hi Ben,

kannst du mir den Inhalt des Verzeichnis redaxo/include/generated/articles zur Verfügung stellen?
LG,
Xong

Bild Määääääääääääääääääääääääh!

Ben
Beiträge: 73
Registriert: 15. Aug 2006, 13:48
Wohnort: Rostock

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 10:58

Hallo Xong,
Würde ich gerne aber das sind 2500 Dateien.... :-(

Ben

Benutzeravatar
Xong
Beiträge: 2081
Registriert: 5. Jun 2008, 08:30
Wohnort: Halle (Saale)

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 11:09

Hi Ben!

Dann such dir selbst mal die Datei des betroffenen Artikels (ARTICLE_ID.0.content) und poste den Inhalt.
LG,
Xong

Bild Määääääääääääääääääääääääh!

Ben
Beiträge: 73
Registriert: 15. Aug 2006, 13:48
Wohnort: Rostock

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 11:19

Tja,
443 gibts da garnicht...

Kommt 442 und dann 444....

Benutzeravatar
Xong
Beiträge: 2081
Registriert: 5. Jun 2008, 08:30
Wohnort: Halle (Saale)

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 11:22

Hi Ben,

wie lautet denn die ID des Artikels? Du hast doch nicht die 443 aus der Fehlermeldung genommen, oder? Das ist eine Zeilenangabe. =)
LG,
Xong

Bild Määääääääääääääääääääääääh!

Benutzeravatar
Thomas.Blum
Entwickler
Beiträge: 5063
Registriert: 24. Aug 2004, 22:11
Wohnort: Dresden
Kontaktdaten: Website

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 11:46

Hej,

es liegt daran das 3.x den Cache nach Klick auf "Regeneriere Artikel & Cache" komplett aufbaut. Wenn hier die Skriptzeit nicht reicht, kann es passieren das bestimmte Objekte nicht zur Verfügung stehen.

Ich würde die Seite eher auf 4.x aktualisieren. denn bei 4.x wird der Cache bei Aufruf generiert und nciht komplett auf einmal.

vg Thomas

Ben
Beiträge: 73
Registriert: 15. Aug 2006, 13:48
Wohnort: Rostock

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 11:55

Hey,

heißt das jetzt ich kann nix mehr machen, außer auf Redaxo 4.0 umstellen?
Kann ich das Problem auch noch irgendwie in der Version ändern? So dass das erstmal wieder läuft, dann kann ich immernoch auf 4.0 umstellen....

Gruß,
Ben

Benutzeravatar
Xong
Beiträge: 2081
Registriert: 5. Jun 2008, 08:30
Wohnort: Halle (Saale)

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 12:12

Du kannst versuchen, die Scriptlaufzeit in der /redaxo/index.php ganz am Anfang der Datei hochzusetzen:

Code: Alles auswählen

ini_set('max_execution_time', 0);
ini_set('memory_limit', '1024M');
LG,
Xong

Bild Määääääääääääääääääääääääh!

Benutzeravatar
Thomas.Blum
Entwickler
Beiträge: 5063
Registriert: 24. Aug 2004, 22:11
Wohnort: Dresden
Kontaktdaten: Website

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 13:57

Es gab m.E. ein AddOn oder Modul was den Cache onthefly generiert. Weiß aber nicht mehr wo es zu finden ist. Ist schon zu lang her.

Benutzeravatar
Xong
Beiträge: 2081
Registriert: 5. Jun 2008, 08:30
Wohnort: Halle (Saale)

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 14:06

Thomas.Blum hat geschrieben:Es gab m.E. ein AddOn oder Modul was den Cache onthefly generiert. Weiß aber nicht mehr wo es zu finden ist. Ist schon zu lang her.
Ich hab ehrlich gesagt noch nie eine Redaxo-3-Installation live gesehen, zumindest nicht bewusst über´s Backend. =)
LG,
Xong

Bild Määääääääääääääääääääääääh!

Ben
Beiträge: 73
Registriert: 15. Aug 2006, 13:48
Wohnort: Rostock

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 14:31

Hallo,

@ Xong: Muss man nicht gesehen haben die 4.0 Version ist schöner.

Wenn ich Artikel und Bilder usw. lösche wie stehen dann meine Chancen das es mit der Regenerierung von Artikel usw. klapp? Gibt es da Erfahrung wie groß das ganze sein darf?!

Gruß,
Ben

Benutzeravatar
Xong
Beiträge: 2081
Registriert: 5. Jun 2008, 08:30
Wohnort: Halle (Saale)

Re: Regeneriere Artikel & Cache, danach baut Seite nicht auf

14. Sep 2012, 14:36

Ben hat geschrieben:Wenn ich Artikel und Bilder usw. lösche wie stehen dann meine Chancen das es mit der Regenerierung von Artikel usw. klapp? Gibt es da Erfahrung wie groß das ganze sein darf?!
Das hängt ganz vom Server ab.

Theoretisch könntest du dir auch die komplette Site lokal installieren, dort dann den Cache generieren und den Cache hochladen. =)
LG,
Xong

Bild Määääääääääääääääääääääääh!

Zurück zu „Allgemeines [R3]“