Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
morfer
Beiträge: 105
Registriert: 24. Mär 2009, 01:58

Template Weiche: Links werden nicht geparsed

29. Mär 2017, 01:10

Hallo, ich nutze folgende Weiche in meinem Haupttemplate:

Code: Alles auswählen

$PATH = explode("|",$this->getValue("path"));
$article = OOArticle::getArticleById(REX_ARTICLE_ID);
 if ($PATH[1] == 5 && !$article->isStartArticle())
    {
       $navTemplate = new rex_template(2);
       include $navTemplate->getFile();
		exit();
    }
 if ($PATH[1] == 6)
    {
       $navTemplate = new rex_template(3);
       include $navTemplate->getFile();
		 exit();
    }
In der Ausgabe werden dann keine Links im TinyMCE mehr geparsed. Im Frontend steht dann z.B.: redaxo://8

Scheint an der Template Weiche zu liegen. In den beiden Templates wird er Inhalt mit:

Code: Alles auswählen

echo $this->getArticle();
ausgegeben.

Kann man das Problem umgehen?

Redaxo 4.7.1
PHP: 5.6.29-nmm1

morfer
Beiträge: 105
Registriert: 24. Mär 2009, 01:58

Re: Template Weiche: Links werden nicht geparsed

29. Mär 2017, 01:33

Ok habe es so in den eingebundenen Templates hinbekommen:

Code: Alles auswählen

$a = $this->getArticle();
$a = rex_article::replaceLinks($a);
echo $a;
Kann ich das so nutzen, ohne dass mir später irgendwas um die Ohren fliegt?

Zurück zu „Allgemeines [R4]“