zristian
Beiträge: 5
Registriert: 31. Mai 2018, 15:30

Probleme mit Image-Pfaden nach SSL Umstellung...

7. Jun 2018, 09:20

Guten Morgen,
ich bin neu hier im Forum und hatte bisher nicht viel mit Redaxo zu tun.

Nun muss ich aber für einen Kunden eine bestehende Installation auf HTTPS umstellen.

Im Prinzip kein großes Ding und ich habe, nach dem ich mich hier im Forum schlau gelesene habe,
die nötigen Anpassungen am System vorgenommen.

Hab die „htaccess" um eine rewrite Regel erweitert.
Und unter System die $REX['SERVER‘] neu gesetzte.

Es funktioniert auch alles bestens, bis auf das Problem das die Image-Pfade immer noch http:// sind,
und ich trotz vieler Versuche in der "htaccess" keine Einfluss auf diese Pfade habe.

Mein erster Gedanke war, dass Redaxo absolute Pfade in die Datenbank schreibt, (wie in Wordpress)
dem ist aber nicht so.

Irgendwo muss aber dieser Pfad generiert werde, nur leider bin ich bei der Suche bisher nicht fündig geworden.

Hat jemand eine hilfreichen Tipp für mich, woran es liegen könnte.

AddOns vielleicht?

Hab schon viele CMS auf HTTPS umgestellt, und nur mit Redaxo so ein Theater.
Wobei es immer viel schwieriger ist, wenn man die Seite nicht selber erstellt hat.

Viele Grüße
Zristian

Benutzeravatar
RexDude
Beiträge: 2518
Registriert: 22. Apr 2010, 11:24

Re: Probleme mit Image-Pfaden nach SSL Umstellung...

7. Jun 2018, 11:51

Hi, da in REDAXO der Content in Modulen aufgebaut ist, würd ich mal in den Modulausgaben schauen ob sich da ein hartcodierter Pfad versteckt hat. Sonst in den Templates. Der Base Tag, wenns einen gibt, solltest auch überprüfen. Wenn alles nix Hilft geht noch ein globales Ersetzen von http:// zu https:// über den Output Filter Extension Point, bzw. über das Xoutputfilter Addon.

zristian
Beiträge: 5
Registriert: 31. Mai 2018, 15:30

Re: Probleme mit Image-Pfaden nach SSL Umstellung...

12. Jun 2018, 19:19

Danke für die Antwort,
leider bin ich immer noch nicht weiter gekommen.

Ich konnte keinen absoluten Pfad in den Template-Dateien finden.

Hab auch dann mal den "Base Tag" gesetzt, was aber an den absoluten Pfaden nicht geändert hat!

Wie funktioniert das mit dem Output Filter Extension Point, bzw. dem Xoutputfilter Addon?

Kannst du mich grob leiten. Der Kunde würde die Seite gerne verschlüsselt sehen und Redaxo ist so gar nicht meine Baustelle.

Benutzeravatar
RexDude
Beiträge: 2518
Registriert: 22. Apr 2010, 11:24

Re: Probleme mit Image-Pfaden nach SSL Umstellung...

12. Jun 2018, 22:58

Probiers mal mit dem Addon (für R4!): https://redaxo.org/download/addons/xoutputfilter/
Dort alle http:// durch https:// ersetzen fürs Frontend.

Ansonsten musst du die Ausgabe lokalisieren also da wo das Bild ausgegeben wird. Da du nix von Modulen geschrieben hast würd ich da mal gucken.

zristian
Beiträge: 5
Registriert: 31. Mai 2018, 15:30

Re: Probleme mit Image-Pfaden nach SSL Umstellung...

13. Jun 2018, 17:10

Super, das mit dem "xoutputfilter" funktioniert!

Nur wie bekomme ich die Kommentare bei der Ausgabe im Quelltext weg?

Danke für die tolle Hilfe!
Zristian

zristian
Beiträge: 5
Registriert: 31. Mai 2018, 15:30

Re: Probleme mit Image-Pfaden nach SSL Umstellung...

13. Jun 2018, 17:32

Sorry,

die letzte Frage hat sich erledigt!
Bin selber dahinter gekommen.

Noch mal viele lieben Dank für die kompetente Hilfe.

Zristian

Benutzeravatar
RexDude
Beiträge: 2518
Registriert: 22. Apr 2010, 11:24

Re: Probleme mit Image-Pfaden nach SSL Umstellung...

13. Jun 2018, 18:26

:-)
Aber Achtung. Du hast jetzt alle LInks auf https gesetzt (wenn du es so gemacht hast). Also checke auch die externen Links ob sie noch alle gehen ;) Alternativ musst du dein Replace etwas einschränken.

zristian
Beiträge: 5
Registriert: 31. Mai 2018, 15:30

Re: Probleme mit Image-Pfaden nach SSL Umstellung...

14. Jun 2018, 07:25

Danke, aber daran hatte ich schon gedacht und nur den Image-Tag ersetzt.

Aber ein guter Tipp für alle, die diesen Beitrag Lesen und das selbe Problem haben.

Grüße
Zristian

Zurück zu „Allgemeines [R4]“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste